New User Can't Join


#1

A friend of mine (old LPU name : _Depression) can’t pay for the LPU due to the capcha not showing up. Because he can’t make an account, he can’t go to the support site either. How can i get help for him?


#2

It looks like the image thingy works now… if not, and your friend has a twitter; have him tweet @groundctrl for help :slight_smile:


#3

The problem with CAPTCHA still exist.


#4

Just tried to register my friend. Same problem, different error code but problem still exist. Just wrote to ground(ctrl) support, let’s see what they’ll say…


#5

I’m from Germany and had this problem too. I tried various browsers and other stuff but it didn’t work until I wrote an email to the groundctrl support, tweeted to them and Adam and after not an hour it worked.
I guess it has nothing to do with my emailling and tweeting, but maybe it brings you luck :smiley:


#6

I just spoke with Adam, the image is hosted through Google and it’s an issue with Google… Ground(crtl) is working on fixing the issue.

Please pass this along to all you see with this issue :slight_smile: