Trouble with LP Recharge


#1

I was so happy when I recieved my registration code some days ago, until I started playing it. When I click in objects I can fire to, my glove just won’t fire. I can move without any trouble, but shooting isn’t that easy. Besides, the game is far too slow, I don’t know if it’s because of my computer or my internet speed. Can anyone help me with this???


#2

Well, It actually is a litle slow. Your computer and internet speed may affect your gaming experience. Also, (believe it or not) try using internet explorer. Is the only web browser I am able to actually play the game xD


#3

I recieved my code too, but luckily none of those problems that you just told us happened to me.

In my case to aim, shoot and walk was the problem, because all those moviments are made by clicking the mouse… so everytime that I tried to aim and set fire my caracter moved and i missed … well that was just so annoying.

Why dont you try to play in another computer with different internet speed just to see if the problem isn’t yours?

bye!


#4

It is probably your computer. Have you checked if you have all the needed programs to play the game (i.e Adobe flash player)?

It works perfectly fine for me. No lagging, no nothing. I’ve tried on both Google Chrome and Safari and it works just awesome on both.

If you continue to have issues, contact their support team. They’re really fast at getting back at you and fixing (if possible) any problems/bugs you may have :slight_smile:


#5

I’m stuck on basecamp b… how am I supposed to finish that mission?