Weird Forum Bugs


#1

I’ve noticed a couple of forum bugs since I’ve started goofing around. Firstly, and this may just be due to the forums being new and everything still “settling”, but it seems topics randomly appear or disappear in their respective forums and not all of the topics show up at once.

Also, there seems to be a bug with the amount of posts in each forum, unless again there really are that many but some threads are hidden. :stuck_out_tongue:


#2

Post counts jump up and down on my end as well.

EDIT: Another weird bug is that after replying to a thread the Forum navigation links (e.g. Home / Forum / Site Feedback / Weird Forum Bugs) disappear.


#3

I’ve found this is because the redirect URL after posting is incorrect. I just created a thread in the Music Forum, and was redirected to:

http://lpu.linkinpark.com/forum/music-room//page/1

Rather than:

http://lpu.linkinpark.com/forum/music-room/page/1

Just means there’s an unrequired “/” in the redirect.

EDIT: The parser isn’t working quite right. When I create a link, the closing < / a > tag isn’t stripped out, breaking the URL. D’oh!


#4

Also, “< - -” without spaces is treated as the start of a HTML comment (understandable since HTML is on), but it does remove all text that follows.


#5

Another thought I’ve had, is if times were in H:i format rather than simply i. Using i format is fine for periods under an hour, but anything over that starts to look odd (will 23 hours be listed as “1380 minutes ago”.

This isn’t a complaint, merely a suggestion. I’m just happy to have a forum this time around.


#6

I’ve found another bug :slight_smile:

If a member hasn’t set a birthdate, it says the member is 2013 years old. So unless he or she is Methuselah, this is wrong :P. I know how it’s come about code-wise, but perhaps it’s better to simply suppress this part of the bio?

Again it’s not a critical bug, but an observation.


#7

[quote=]I’ve found another bug :slight_smile:

If a member hasn’t set a birthdate, it says the member is 2013 years old. So unless he or she is Methuselah, this is wrong :P. I know how it’s come about code-wise, but perhaps it’s better to simply suppress this part of the bio?

Again it’s not a critical bug, but an observation.


#8

The site isn’t letting me have Bob yet. I’ve contacted one of the staff for advice.


#9

The site isn’t letting me have Bob yet. I’ve contacted one of the staff for advice.


#10

Another suggestion I have (I don’t know how much control you have over the forum software), but it would be useful if each user could set a timezone, which would then be reflected in the timestamps of posts. This isn’t a big deal, merely a thought. :slight_smile: